Ads 468x60px

Monday, May 30, 2011

Maipu Load balancing - Static Routing

Today, in this section we will see about Load balancing using Maipu routers using two ISP. Many time I came across with such kind of requirement from customers. They have two links from two different service providers and to use both links. They want to divide traffic among both links.
                  Here is one simple example. how you can do it. In this senario, customer have /27 pool in LAN. The requirement is 3 host should use one link and two host should use another link.


Here is topology -










Test description -

Under the MP2824 has a Lan interface Sw1, and which IP is 129.255.150.27, under this Lan interface has 5 hosts, some host will go through R2 , some host will go through R3. When the one link was down all the operation will change and everything will work from one link. As the link get restored , it will work as per topology. 


Key Configuration:

ip access-list extended acl1                             ## match host ##
 permit ip host 129.255.150.26 any
 permit ip host 129.255.150.29 any
 exit
ip access-list extended acl2                            ## match host ##
 permit ip host 129.255.150.178 any
 permit ip host 129.255.150.135 any
 permit ip host 129.255.150.35 any
 exit

## Defined two Access list in order to make the route map.

vlan 1
 description default
 port 0-23 untagged
 exit



interface switchethernet0
description ### LOCAL LAN ###
 ip address 129.255.150.27 255.255.0.0
 vlan 1
 ip policy route-map test          ### use the route-map here
 exit


interface fastethernet0
 ip address 1.1.1.1 255.255.255.0
 keepalive 10 gateway 1.1.1.2
 exit



interface fastethernet1
 ip address 2.1.1.1 255.255.255.0
 keepalive 10 gateway 2.1.1.2
exit
            
ip route 0.0.0.0 0.0.0.0 1.1.1.2
ip route 0.0.0.0 0.0.0.0 2.1.1.2

route-map test permit 10
 match ip address acl1
 set ip next-hop 1.1.1.2 2.1.1.2
 exit

route-map test permit 20
 match ip address acl2
 set ip next-hop 2.1.1.2 1.1.1.2
 exit






In this way we can configure Maipu router for Load balancing and redundancy for multiple service provider using route-maps and policy based routing. 


Hope this will helpful for you..


For any feedback and queries, Plz put comment with name and Mail id.. for name you can use Name/URL option in profile.

Friday, May 27, 2011

Maipu Basics


Here I am covering some basics of Maipu Router, which everybody need in daily routine while monitoring Maipu routers.

Topics Covered –
CPU , Memory, Temperature, SSH, Syslog, Boot loader and more…

To check cpu of Maipu Router –

First enable , spy cpu and check cpu enable.
Router# spy cpu
Router# monitor cpu
Router(config)# check cpu enable
Then perform –
Show cpu , sh cpu monitor, show cpu history

Memory

Show memory – for memory

Temperature

You can see temperature on Maipu routers above 2800 series, like 2824, 3800,7200.
 sh environment
        CPU Temperature is 54°C
        MainBoard Temperature is 33°C

You can poll these values using any NMS. For this you require Maipu MIBs.

SSH

Many of Engineers want to enable SSH for secure communication , Here find the configuration required for SSH.

Step 1 -
 First create the crypto key:

router(config)#sshkeygen

        Generating host key ... ...

        Host key Generated!

After that perform below configuration :

hostname router
user admin privilege 15 password 0 admin

interface fastethernet0
 ip address 192.168.1.1 255.255.255.0
 exit

line ssh-vty 0 15
 privilege level 15
 password 0 admin
 login
 exit
            
ip ssh server

show command – show fingerprint
Output –
The public key sha1 fingerprint:

        Key length: 1024
        89:95:4f:7d:54:f0:6d:19:5a:c9:a7:6d:b5:f3:7d:e3:14:c4:8f:bd

The public key md5 fingerprint:

        Key length: 1024
        4e:ea:be:3e:b0:95:04:47:08:7f:fb:bc:a0:23:39:04

Boot Loader

To check which is your booting IOS or IOS preference-
router(config-fs)#show boot-loader
Basically this command will be helpful, when you have two IOS in flash. Some time you want to see which is active IOS and which IOS will be active after booting.

Syslog

The log messages are graded from level 0 to level 7 according to the
severity levels. Level 0 means the message level is the most severe. By
default, the information of level 0 -7 is all printed to the console interface;
if the terminal monitor command is configured on the telnet terminal;
the information of level 0-5 is written to the memory file; the information
of level 0-4 are written into the flash file; the information of level 0-5 is
sent to the log server.


router(config)#logging file ?    ### you can define level of logging ###

<0-7> Logging severity level
alerts                             Immediate action needed (severity=1)
critical                           Critical conditions (severity=2)
debugging                      Debugging messages (severity=7)
emergencies                   System is unusable (severity=0)
errors Error                   conditions (severity=3)
informational                  Informational messages (severity=6)
notifications                    Normal but significant conditions (severity=5)
warnings                       Warning conditions (severity=4)

The information levels are defined as follows:
Level Key Word Description
0   emergencies The system is unusable.
1   alerts You need to take action at once.
2   critical The critical statue
3   errors The error statue
4   warnings The warning status
5   notifications Normal status, but needs to be noticed
6   informational The informational messages
7   debugging The debugging information


More on /off

When you want to take some capture from your telnet session and your configuration is too long. Then many time you need to hit space button.
Here you can type – more off – in priviledge mode
It will not break configuration into pages.
Then again more on  - for normal usage

                                                                                      
Hope this basic information will be useful for you.

For feedback and queries , Plz put comment with Name and mail id.

You can use Name/URL in profile for comments. 

Maipu IOS upgradation - Shell Mode


Maipu Shell Mode upgradation

As yesterday, I shared Monitor upgradation document. Here is shell upgradation document. But I want add one statement. If you have very old IOS , Check the compile date , you will come to know. That time may be this document will not help you.

In that case you can leave a comment with your mail id. I will try to find it and mail to you. Since in Maipu for old IOS they shell upgradation steps are different. Not easy like this.  But this process is suitable for IOS which are complied by 2009 and 2010.

Maipu is gradually changed the IOS upgradation process and made easy for user to do it.
For more direct help you can contact maipu – techsupport@maipu.com.

Here Plz have a look on process.
First login remotely to router by telnet, Backup your configuration using FTP,

Process –

Goto filesystem, perform dir and check the files, you will see startup file. We need to copy that to our FTP server.

Setup FTP Server as shown in previous post of IOS upgradation

MP2818#filesystem

MP2818(config-fs)#dir
  size          date       time       name
--------       ------     ------    --------
18826       JAN-08-1980  16:32:08   startup           
10225       JAN-01-1980  00:05:04   history           
102369      JAN-09-1980  19:14:28   logging           
8771804    JAN-01-1980  00:07:12   rp8-i-6.1.7(rl10-ag).bin  
1024         JAN-01-1980  00:03:46   rollback          


2               JAN-01-1980  00:24:24   PKISTORE         
8705787    JAN-01-1980  00:06:02   rp8-i-6.2.47.bin  
1024        JAN-01-1980  00:00:12   snmp              

1144        JAN-01-1980  00:02:28   VG1statup         
13728      JAN-01-1980  00:34:12   fsm.dat           
1              JAN-01-1980  00:00:14   code.dat          
3987       JAN-01-1980  21:26:04   excetech          


MP2818(config-fs)#copy file-system /flash/startup ftp 115.242.38.13 maipu maipu  startup
Copying!!!!!!!!!!!!!!!!!!!
Total 18826 bytes copying completed.
MP2818(config-fs)#exit
Startup Copied.. 


Then perform …


  •     Use sysupdate command to upgrade monitor first.

   command: Make sure you specify monitor after monitor file.
     sysupdate   monitor ftp
      system prompt:
                                Update monitor flash:
                                Erase monitor flash ... success.
                                Programming monitor flash ........ success.
                                Verifying monitor flash ... success.



Important : after upgrading monitor, PLEASE DON'T shutdown or reload router, and do next step right now.


  • Use sysupdate command to upgrade IOS.

   command: Make sure you specify image after IOS name
     sysupdate   image ftp



  •           Reload router.


IOS upgradation completed.

In this process, Major concentration should be, Image and monitor keywords. Specify monitor when you are upgrading monitor file to router and specify image when you are upgrading any IOS image.

Now we completed both upgradation mode for Maipu routers.
Same time we saw how to take backup of Maipu Router configuration.

Hope this Information will help you in real time..

Thanks for reading.

For feedback and queries, Plz comment with Name and Mail id.
Those who don’t have any account with blogger, just use Name/url  in profile. It will show your name..


Thursday, May 26, 2011

Maipu 3G configurations


Now a days, Many customers are looking for cheap backup solution for primary link, so many ISP are offering 3G link (inform of USB or sim card) as backup link.
In mean time they can restore primary, customer can use 3G as backup for continuation in operations.
Maipu has MP 1800 series dedicated for 3G CPE routers.

This is tested configuration for one of case.But here we are using 2 cellular media, one is 3G from SIM card and other is from USB. This is quite intresting , Both can be used same time. One as primary and other as backup.
Many customer requires this kind of solution.

Testing description

MP1800 router as the CPE in the customer life network, interface cellular 3/0 as the primary link , link type is GPRS (3G) and USB interface as the backup link also via the GPRS network  cellular0.

When the master link was down, router will automatically change to the backup link.

Totally customer has two link, one for primary and other one for link backup.

Maipu 1800 key configuration:

ip mef

ip load-sharing per-destination

ip access-list standard 1
 10 permit any
 exit

dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit

chat-script g3dia ATDT

interface fastethernet0
 ip address 172.29.1.1 255.255.255.252
 exit

interface tunnel1
 tunnel source 10.203.176.22        ## IP address are received from SP after authentication ##
 tunnel destination 172.29.5.210     ## IP address are received from SP after authentication ##
 ip address 192.211.1.2 255.255.255.252
 exit


interface tunnel2
 tunnel source 10.111.20.32           ## IP address are received from SP after authentication ##
 tunnel destination 172.30.233.15     ## IP address are received from SP after authentication ##
 ip address 192.212.1.2 255.255.255.252
 ip ospf cost 30000
 exit

!hsc_if_cellular0

interface cellular0                              ### USB Cellular ###
 encapsulation ppp
 ppp chap password ow
 ppp ipcp dns request
 ip address negotiated
 bandwidth 384
 dialer in-band
 dialer idle-timeout 0
 dialer-group 1
 dialer string *99#
 script dialer g3dia
 ui-control inaccessible telnet http
 exit

!end

!hsc_if_cellular3/0

interface cellular3/0                  ### SIM card used for connectivity ###
 encapsulation ppp
 ppp chap password ow
 ppp ipcp dns request
 ip address negotiated
 bandwidth 384
 dialer in-band
 dialer idle-timeout 0
 dialer-group 2
 dialer string *99#
 script dialer g3dia
 ui-control inaccessible telnet http
 exit       
                                  
router ospf 100
 network 172.29.1.0 0.0.0.255 area 0
 network 192.211.1.0 0.0.0.255 area 0
 network 192.212.1.0 0.0.0.255 area 0
 exit

ip route 0.0.0.0 0.0.0.0 cellular0
ip route 0.0.0.0 0.0.0.0 cellular3/0



Hope this configuration will be helpful for you.

For feedback and queries, Plz comment with your name and mail id..


Maipu – IOS upgradation


Maipu – IOS upgradation from Monitor Mode

Maipu has two ways to upgrade the IOS, one is from monitor mode, similar to Cisco ROMMON mode. Then another is from shell mode that means privilege mode. Same like Cisco. But, Maipu has some command differences. Many of you know that Maipu upgradation is very complicated. But now Maipu already launched simplest way to do it with 2 simple steps in shell mode “sysupdate”.

I know many of engineer are looking for document reference for Maipu IOS upgradation. Here I will cover both upgradation process. Monitor mode and Shell mode.

In this section, we will see how to upgrade IOS Maipu IOS from monitor mode…

Note : this is general process. For confirmation you can contact Maipu directly – techsupport@maipu.com
  
To enter in monitor mode – Plz press “Ctrl+C” at the time of booting, if you are not able to go, Plz reboot router manually and try again.

Monitor upgradation process is used in recovery mode. If you face any issue in upgrading router by normal mode and it is not coming up, then you have to use this mode… normally this mode is very easy and fast to recover router to normal with required IOS.

Make the environment like this, Use straight cable to connect your laptop to router f0 port or g0 port depending on router models. Then connect console to your laptop.

That means now you can access router via hyper terminal from your laptop and your laptop is connected to router by straight cable also.


As best practice, we can take backup of our configuration for our records.

Backup your startup file to your FTP server --
(This is according to your requirement)

Command:

ftpcopy [src /path/filename] ftp [host addr] [user] [pass] [dest filename]         
- copy file from flash to host with FTP
Under the monitor mode:
Monitor:>ftpcopy /flash/startup ftp 1.1.1.2 maipu maipu startup.txt
Copying!!!
Total 2629 bytes copying completed.

Check the monitor version and format

Monitor:>ver
This will show you current monitor details
Monitor:>


Sometime this command will not work, depending upon the models…
Use “format /flash” then confirm with “Y”

Monitor:>format /flash
All files in TFFS dev /flash system will lose, realy want to format(Y/N)?Y
Erasing TFFS dev '/flash' ..................…….............................success!
Formatting TFFS dev '/flash'  ..................…….............................success!
mount flash file system on dev '/flash' success.



This format/system command is for double file system IOS and supported models like
MP1800, MP 2824 and MP 3840.

Monitor:>format /system   
All files in TFFS dev /system system will lose, realy want to format(Y/N)?Y
Erasing TFFS dev '/system'  ..................…….............................success!
Formatting TFFS dev '/system'  ..................…….............................success!
mount flash file system on dev '/system' success


Change the hyper terminal speed to 115200 , use XMODEM upgrade the monitor.
Monitor:>s 115200 
### change the speed from 9600 to 115200, after that please also change your hyper terminal speed to 115200 and re-open it.

Monitor:>
Monitor:>lxr
download monitor image <.bin> with xmodem protocol:
XMODEM Receive: Waiting for Sender ...
CCC
download success, image size = xxxxxx ( xxxxxx ).
Update monitor flash........
Monitor:>

Now from here itself you can upgrade IOS also by XModem, But it will take lot of time.
To do it fast we have use our PC and FTP to upload IOS to Router.

Setup FTP server on PC, set the IOS path and username, password in that software.

I am using - wftpd32 software to do this.

Check out – that software steps.



Click –Security àUser/rights-- > new user

Then create new user à and in home directory locate the path of IOS àclick Done.



In this way, your FTP configuration is complete. Make sure that correct IOS is located in home Directory.


Now back to hyperterminal
For help in monitor mode- type “help” , you will see command and decription.

Use ‘C” command to set booting parameter on monitor mode. C- means Change

Monitor:>c
Please change the system boot parameters with the following operation:
'.' = clear field;  '-' = go to previous field;  ^D = quit
available boot devices:
 fe0 fe1 flash
boot device                           : flash0 fe0
file name                              : /flash/rpl-i-6.1.7.bin rpl-i-6.1.25(REL).bin
local IP addr                          : x.x.x.x  1.1.1.1   Assign IP address to router F0 port 
host IP addr                          : 1.1.1.2   Define your FTP server IP shown in diagram 
gateway IP addr                     :
user name                             :  maipu      ### FTP username ##
ftp password                          :  maipu      ### FTP password ##
save image                            :  0 1         ### Type 1, since 1 means save IOS ###

Screenshot -  

### Don’t bother about IOS name in screenshot. IOS will be as per your model and requirement. I tried to explain you process, Diagram is just for reference…

Monitor:>

Then , check once again for confirmation. Using C command, then proceed for last step…
Now already you defined all parameters in router monitor mode, about FTP server and IOS name , username , password.

Now you need to type ‘r’ command in monitor mode. “r” means Run – This command will upload FTP server home directory IOS to your router Flash and boot it.

Monitor:>r


In this way monitor IOS upgradation is completed..

Now one more thing, As we taken backup of your configuration. Copy again to your router and load it…

router(config)#inter f0
router(config-if-fastthernet0)#ip add 1.1.1.1 255.255.255.0

## configure the IP address for interface F0, which is connect to FTP server.

router(config-if-fastethernet0)#exit
router(config)#exit
router#

### check the connectivity is ok from router to FTP server , ping 1.1.1.2 (FTP server)…

router#ping 1.1.1.2
Press key (ctrl + shift + 6) interrupt it.
Sending 5, 76-byte ICMP Echos to 1.1.1.2 , timeout is 2 seconds:
!!!!!
Success rate is 100% (5/5). Round-trip min/avg/max = 0/0/0 ms.

### go to the filesystem, from the FTP copy startup to device flash.    

router#filesystem
router(config-fs)#copy ftp 1.1.1.2 maipu maipu startup.txt file-system /flash/startup
Downloading###OK!

router(config-fs)#

## Now at last you need use command “config-file /flash/startup” to active copied configuration to running-config, otherwise when you need reboot the device then you can get startup when you perform show run.

router(config-fs)#config-file /flash/startup
router(config-fs)#


This section is totally for Maipu monitor upgradation process. In next post we will see about Shell upgradation.

Hope this information is informative for you..

For feedback and queries, Plz put comment with Name and mail id..



Related Posts Plugin for WordPress, Blogger...