Ads 468x60px

Showing posts with label LAB. Show all posts
Showing posts with label LAB. Show all posts

Thursday, November 24, 2011

Maipu - Failover Configuration Using Static Route

Hi , I want to share one testing report with all of you. This is majorly focused on Fail over configuration with static routing.. Below are objectives for testings...

Objective - 
  • R1 Client Router both interface should be UP every time.
  • PC should ping 20.1.1.1 Loopback interface continuously.
  •  Auto Failover should happen.
  • One time one port should forward traffic to ISP router.
  • As the primary F0 links fails, The F1 should get active to forward traffic to ISP router.
  • After restoration of F0 links, The F0 should forward the traffic to ISP router.
Topology:





Configurations

(Client)R1-

interface fastethernet0
 ip address 10.20.20.2 255.255.255.0
 media-type fiber
 rate 100
 duplex full
 load-interval 30
 exit


interface fastethernet1
 ip address 10.20.30.2 255.255.255.0
 media-type fiber
 rate 100
 duplex full
 load-interval 30
  exit


interface vlan1
 ip address 10.1.1.1 255.255.255.0
 exit



ip route 0.0.0.0 0.0.0.0 fastethernet0
ip route 0.0.0.0 0.0.0.0 fastethernet1 10


(ISP)R2 –

interface loopback0
 ip address 20.1.1.1 255.255.255.0
 exit


interface fastethernet0
 ip address 10.20.20.1 255.255.255.0
 media-type fiber
 keepalive gateway 10.20.20.2 4
 rate 100
 duplex full
 load-interval 30
 exit


interface fastethernet1
 ip address 10.20.30.1 255.255.255.0
 media-type fiber
 keepalive gateway 10.20.30.2 4
 rate 100
 duplex full
 load-interval 30
 exit


ip route 10.1.1.0 255.255.255.0 10.20.20.2
ip route 10.1.1.0 255.255.255.0 10.20.30.2 10

Testing Scenarios – 

10.1.1.2  ping to Gateway to observe delay….


10.1.1.2  (PC) ping to 20.1.1.1 (Loopback interface in ISP Router)


Currently in this screen shot, both interface as UP. Primary link F0 is forwarding traffic to ISP router.


After Primary link is down –
You can see F0 is down and F1 is up, F1 is forwarding traffic to ISP router.


Below is ping snap shot from 10.1.1.2 (PC)  to 20.1.1.1 ( ISP loopback interface)


10.1.1.2 (PC) pinging to Gateway IP


After restoration of link
As the link is restored, F0 interface is active interface to forward traffic to ISP router.


The F1 forwarding is shifted to F0 interface.  PC (10.1.1.2) pinging to ISP router loopback (20.1.1.1)


PC pinging to Gateway 10.1.1.1




Above testing successfully demonstrates above objectives are successfully. 

Hope this information will help you. 

Thanks for reading.. 

For feedback. Plz comment with Name and Mail ID.. 








Tuesday, October 11, 2011

Maipu 1800 IPv6 Testing - BGP+


MP1800 -xx Series Routers support OSPFv3, IPv6 RIPng, IPv6 IS-IS, IPv6 BGP4+ and static IPv6 routing.

In this section we will use above topology for IPv6 BGP+ testing. 

Configuration Template -

Router-A:

hostname R-A
ip mef

interface loopback0
 ipv6 enable
 ipv6 address 1::1/128
 exit

interface fastethernet0
 ipv6 enable
 ipv6 address 192::1/64
 exit
                            
router bgp 100
 no auto-summary
 no synchronization
 bgp router-id 1.1.1.1
 neighbor 192::2 remote-as 200
 no neighbor 192::2 activate
 address-family ipv6
  network 1::1/128  
###network loopback 0 into BGP+ session, then peer BGP neighbor can learned this routing ###
  neighbor 192::2 activate
  exit-address-family
 exit


Router-B:


hostname R-B

interface fastethernet0
 ipv6 enable
 ipv6 address 192::2/64
 exit

interface fastethernet1
 ipv6 enable
 ipv6 address 193::1/64
 exit
                                 
router bgp 200
 no auto-summary
 no synchronization
 bgp router-id 2.2.2.2
 neighbor 192::1 remote-as 100
 no neighbor 192::1 activate
 address-family ipv6
  neighbor 192::1 activate
  exit-address-family
 exit



Testing Results Output:

On Router - A


On Router - B


Router-B Routing Table:


Router-B can reach to Router-A Loopback 1::1/128.



This above testing is basic testing of IPv6. For more detailed configurations. You can download it from Maipu website.

Hope this post will help you for IPv6 understanding.

Thanks for reading ...




Tuesday, June 7, 2011

QinQ - Maipu Configurations


In last post, As we discussed about QinQ. Let’see in action, The same thing.Here we will see selective QinQ. Since this most used QinQ style.

For Basic no need to give any Vlan mapping. It will work by default with port pvid.Just you need to enable vlan dot1q tunnel under port. Then it will tag incoming vlan with port vlan and while going out of network. It will remove the Service provider vlan tag. 

Here we can see selective QinQ....

PE1 and PE2 are the operator’s network devices; Customer A, Customer B and Customer C are the user network devices.

Networking requirement: VLAN 10 packets of Customer A and VLAN 10 packets of Customer C are inter-communicated via VLAN 100 of the operator network. VLAN 20 packets of Customer B and VLAN 20 packets of Customer C are inter-communicated via VLAN 200 of the operator network.

Topology                          


PE1 configuration:

Command
Description
PE1(config-port-0/1)#port mode hybrid
Set the port as Hybrid port
PE1(config-port-0/1)#port hybrid untagged vlan 100
Add the port to VLAN 100
PE1(config-port-0/1)#vlan dot1q-tunnel enable
Enable the basic vlan dot1q-tunnel function on the port
PE1(config-port-0/1)#vlan dot1q-tunnel 10 100
The port configures flexible items and encapsulates outer Tag 100 for received VLAN 10 packets.
PE1(config-port-0/1)#vlan dot1q-tunnel drop
The port configuration only supports flexible items.
PE1(config-port-0/2)#port mode hybrid
Set the port as Hybrid port
PE1(config-port-0/2)#port hybrid untagged vlan 200
Add the port to VLAN 200
PE1(config-port-0/2)#vlan dot1q-tunnel enable
Enable the basic vlan dot1q-tunnel function on the port
PE1(config-port-0/2)#vlan dot1q-tunnel 20 200
The port configures flexible items and encapsulates outer Tag 200 for received VLAN 20 packets.
PE1(config-port-0/2)#vlan dot1q-tunnel drop
The port configuration only supports flexible items.
PE1(config-port-0/3)#port mode trunk
Set the port as Trunk port
PE1(config-port-0/3)#port trunk allowed vlan 100
Set port 0/3 to allow VLAN 100 to pass
PE1(config-port-0/3)#port trunk allowed vlan 200
Set port 0/3 to allow VLAN 200 to pass

PE2 configuration:

Command
Description
PE2(config-port-0/2)#port mode hybrid
Set the port as Hybrid port
PE2(config-port-0/2)#port hybrid untagged vlan 100
Add the port to VLAN 100
PE2(config-port-0/2)#port hybrid untagged vlan 200
Add the port to VLAN 200
PE2(config-port-0/2)#vlan dot1q-tunnel enable
Enable basic vlan dot1q-tunnel function on the port
PE2(config-port-0/2)#vlan dot1q-tunnel 10 100
The port configures flexible items and encapsulates outer Tag 100 for received VLAN 10 packets.
PE2(config-port-0/2)#vlan dot1q-tunnel 20 200
The port configures flexible items and encapsulates outer Tag 200 for received VLAN 20 packets.
PE2(config-port-0/2)#vlan dot1q-tunnel drop
The port configuration only supports flexible items.
PE2(config-port-0/3)#port mode trunk
Set the port as Trunk port
PE2(config-port-0/3)#port trunk allowed vlan 100
Set port 0/3 to allow VLAN 100 to pass
PE2(config-port-0/3)#port trunk allowed vlan 200
Set port 0/3 to allow VLAN 200 to pass
Note -
The user must ensure that the network devices between PE1 and PE2 can permit vlan dot1q tunnel packets to pass via configuration.

Monitoring Commands

Command
Description
show vlan dot1q-tunnel
View the information about the flexible vlan dot1q-tunnel items
show vlan dot1q-tunnel mapping
View the information about the flexible vlan dot1q-tunnel mapping items
show frame-tag tpid
View all port TPID information

Monitoring Command Output - show outputs are for reference , not actual*

switch#show vlan dot1q-tunnel

Displayed result:
switch#show vlan dot1q-tunnel
-------------------- ------------VLAN DOT1Q-TUNNEL-----------------------
Port                     Inner VlanId             Outer VlanId            
-------------------- --------------------- ----------------------------------------------
port 0/1                 totals:2
                                  10                              100                     
                                  15                              150                     
port 0/2                 totals:1
                                  20                              200                     

Description and analysis:

Port: port name
Inner VlanId: The VLAN ID of the Tag packets received by the port, that is, the inner VLAN ID of the packets after encapsulation.
Outer VlanId: The outer VLAN ID encapsulated by the port, that is, the outer VLAN ID of the packets after encapsulation

The displayed result shows the flexible vlan dot1q-tunnel items configured on the port and the details.

switch#show vlan dot1q-tunnel mapping

Displayed result:
-------------------- -------VLAN DOT1Q-TUNNEL MAPPING--------------------
Port                     Former VlanId            Mapping VlanId           
-------------------- --------------------- ----------------------------------------------------
port 0/4                 totals:1
                                  40                                400                     
port 0/5                 totals:2
                                  40                                400                     
                                 50                                 500                     
port 0/6                totals:1
                                 40                                400 

Description and analysis:

Port: port name
Former VlanId: The VLAN ID of the Tag packets received by the port, that is, the VLAN ID of the Tag in the packet before replacing
Outer VlanId: The VLAN ID used by the port for replacing as per the flexible items, that is, the VLAN ID used to replace Tag

The displayed result shows the flexible vlan dot1q-tunnel mapping items configured on the port and the details.

Hope this configuration will help you for better understanding of QinQ functions.

For any queries and feedback, Plz put comment with your Name and Mail id..


Monday, May 30, 2011

Maipu Load balancing - Static Routing

Today, in this section we will see about Load balancing using Maipu routers using two ISP. Many time I came across with such kind of requirement from customers. They have two links from two different service providers and to use both links. They want to divide traffic among both links.
                  Here is one simple example. how you can do it. In this senario, customer have /27 pool in LAN. The requirement is 3 host should use one link and two host should use another link.


Here is topology -










Test description -

Under the MP2824 has a Lan interface Sw1, and which IP is 129.255.150.27, under this Lan interface has 5 hosts, some host will go through R2 , some host will go through R3. When the one link was down all the operation will change and everything will work from one link. As the link get restored , it will work as per topology. 


Key Configuration:

ip access-list extended acl1                             ## match host ##
 permit ip host 129.255.150.26 any
 permit ip host 129.255.150.29 any
 exit
ip access-list extended acl2                            ## match host ##
 permit ip host 129.255.150.178 any
 permit ip host 129.255.150.135 any
 permit ip host 129.255.150.35 any
 exit

## Defined two Access list in order to make the route map.

vlan 1
 description default
 port 0-23 untagged
 exit



interface switchethernet0
description ### LOCAL LAN ###
 ip address 129.255.150.27 255.255.0.0
 vlan 1
 ip policy route-map test          ### use the route-map here
 exit


interface fastethernet0
 ip address 1.1.1.1 255.255.255.0
 keepalive 10 gateway 1.1.1.2
 exit



interface fastethernet1
 ip address 2.1.1.1 255.255.255.0
 keepalive 10 gateway 2.1.1.2
exit
            
ip route 0.0.0.0 0.0.0.0 1.1.1.2
ip route 0.0.0.0 0.0.0.0 2.1.1.2

route-map test permit 10
 match ip address acl1
 set ip next-hop 1.1.1.2 2.1.1.2
 exit

route-map test permit 20
 match ip address acl2
 set ip next-hop 2.1.1.2 1.1.1.2
 exit






In this way we can configure Maipu router for Load balancing and redundancy for multiple service provider using route-maps and policy based routing. 


Hope this will helpful for you..


For any feedback and queries, Plz put comment with name and Mail id.. for name you can use Name/URL option in profile.

Related Posts Plugin for WordPress, Blogger...