Ads 468x60px

Showing posts with label Solutions. Show all posts
Showing posts with label Solutions. Show all posts

Thursday, November 24, 2011

Maipu - Failover Configuration Using Static Route

Hi , I want to share one testing report with all of you. This is majorly focused on Fail over configuration with static routing.. Below are objectives for testings...

Objective - 
  • R1 Client Router both interface should be UP every time.
  • PC should ping 20.1.1.1 Loopback interface continuously.
  •  Auto Failover should happen.
  • One time one port should forward traffic to ISP router.
  • As the primary F0 links fails, The F1 should get active to forward traffic to ISP router.
  • After restoration of F0 links, The F0 should forward the traffic to ISP router.
Topology:





Configurations

(Client)R1-

interface fastethernet0
 ip address 10.20.20.2 255.255.255.0
 media-type fiber
 rate 100
 duplex full
 load-interval 30
 exit


interface fastethernet1
 ip address 10.20.30.2 255.255.255.0
 media-type fiber
 rate 100
 duplex full
 load-interval 30
  exit


interface vlan1
 ip address 10.1.1.1 255.255.255.0
 exit



ip route 0.0.0.0 0.0.0.0 fastethernet0
ip route 0.0.0.0 0.0.0.0 fastethernet1 10


(ISP)R2 –

interface loopback0
 ip address 20.1.1.1 255.255.255.0
 exit


interface fastethernet0
 ip address 10.20.20.1 255.255.255.0
 media-type fiber
 keepalive gateway 10.20.20.2 4
 rate 100
 duplex full
 load-interval 30
 exit


interface fastethernet1
 ip address 10.20.30.1 255.255.255.0
 media-type fiber
 keepalive gateway 10.20.30.2 4
 rate 100
 duplex full
 load-interval 30
 exit


ip route 10.1.1.0 255.255.255.0 10.20.20.2
ip route 10.1.1.0 255.255.255.0 10.20.30.2 10

Testing Scenarios – 

10.1.1.2  ping to Gateway to observe delay….


10.1.1.2  (PC) ping to 20.1.1.1 (Loopback interface in ISP Router)


Currently in this screen shot, both interface as UP. Primary link F0 is forwarding traffic to ISP router.


After Primary link is down –
You can see F0 is down and F1 is up, F1 is forwarding traffic to ISP router.


Below is ping snap shot from 10.1.1.2 (PC)  to 20.1.1.1 ( ISP loopback interface)


10.1.1.2 (PC) pinging to Gateway IP


After restoration of link
As the link is restored, F0 interface is active interface to forward traffic to ISP router.


The F1 forwarding is shifted to F0 interface.  PC (10.1.1.2) pinging to ISP router loopback (20.1.1.1)


PC pinging to Gateway 10.1.1.1




Above testing successfully demonstrates above objectives are successfully. 

Hope this information will help you. 

Thanks for reading.. 

For feedback. Plz comment with Name and Mail ID.. 








Tuesday, October 11, 2011

Maipu 1800 IPv6 Testing - BGP+


MP1800 -xx Series Routers support OSPFv3, IPv6 RIPng, IPv6 IS-IS, IPv6 BGP4+ and static IPv6 routing.

In this section we will use above topology for IPv6 BGP+ testing. 

Configuration Template -

Router-A:

hostname R-A
ip mef

interface loopback0
 ipv6 enable
 ipv6 address 1::1/128
 exit

interface fastethernet0
 ipv6 enable
 ipv6 address 192::1/64
 exit
                            
router bgp 100
 no auto-summary
 no synchronization
 bgp router-id 1.1.1.1
 neighbor 192::2 remote-as 200
 no neighbor 192::2 activate
 address-family ipv6
  network 1::1/128  
###network loopback 0 into BGP+ session, then peer BGP neighbor can learned this routing ###
  neighbor 192::2 activate
  exit-address-family
 exit


Router-B:


hostname R-B

interface fastethernet0
 ipv6 enable
 ipv6 address 192::2/64
 exit

interface fastethernet1
 ipv6 enable
 ipv6 address 193::1/64
 exit
                                 
router bgp 200
 no auto-summary
 no synchronization
 bgp router-id 2.2.2.2
 neighbor 192::1 remote-as 100
 no neighbor 192::1 activate
 address-family ipv6
  neighbor 192::1 activate
  exit-address-family
 exit



Testing Results Output:

On Router - A


On Router - B


Router-B Routing Table:


Router-B can reach to Router-A Loopback 1::1/128.



This above testing is basic testing of IPv6. For more detailed configurations. You can download it from Maipu website.

Hope this post will help you for IPv6 understanding.

Thanks for reading ...




Wednesday, July 20, 2011

Link Aggregation - Maipu and Cisco

Today we will discuss about Link aggregation, This is very important topic in switching. This is many times used in Enterprises network for trunking. Basically this will help to bind several physical links together to form a logical link and it can be used to increase link bandwidth for trunk. Meanwhile, each aggregation member link can achieve dynamic backup with each other to provide higher connection reliability.

This section describes the concept of the link aggregation. Main contents:
  • Terms of the link aggregation
  • Functions of the link aggregation
  • LACP protocol


Terms of the Link Aggregation

Link aggregation: multiple physical links are bound together to form a logical link, which expands the link bandwidth. At the same time, the member links of the aggregation are dynamic backup mutually. It provides higher reliability.

  • LAC: Link Aggregation Control
  • LACP: Link Aggregation Control Protocol, defined in IEEE802.3ad.
  • LACPDU: Link Aggregation Control Protocol Data Unit.
  • LAG: Link Aggregation Group.
  • LAG ID: Link Aggregation Group Identifier.
  • Key: 16-bit integer variable, for describing the aggregation capability of a port. It is composed of rate, duplex, and administrative key (aggregation group ID).
  • Administrative Key: The key used by the administrator for setting.
  • Operational Key: The key reflecting the port aggregation capability.


Functions of the Link Aggregation

The link aggregation is a aggregation group composed of multiple ports. The upper layer entities using the link aggregation service regard the multiple physical links in the same aggregation group as a logical link. The function of the link aggregation is to share the in/out load in each member port to increase the link bandwidth. At the same time, member ports of the aggregation group are dynamic backup mutually. It provides higher reliability.

LACP Protocol

IEEE802.3ad-based LACP is a protocol for implementing the link dynamic aggregation. The LACP protocol communicates with the opposite end through the Link Aggregation Control Protocol Data Unit (LACPDU). After the LACP protocol of a port is enabled, the port advertises the system priority, system MAC address, port priority, port number, and the operation key to the opposite end by sending LACPDU. After the opposite end receives the information, compare the information with the information saved in other ports to select port to aggregate. As a result, the two parties can agree with each other on joining or exiting a dynamic aggregation group. The operation key is a configuration combination generated by the LACP protocol according to the port configuration (rate, duplex, administrative key).

Classification of Link Aggregation

The link aggregation can be classified into two types according to the aggregation mode:
  • Manual aggregation
  •  LACP protocol aggregation

Below are configuration examples for both modes.

Configuration for Link Aggregation

Topology

LAC configuration

As figure above, ports 0/1-0/3 between two switches connect with each other. Local switch switch1 aggregates peer switch switch2; three ports of each side participate in the aggregation. Suppose that the numbers of the ports that participate in the aggregation at the two sides are all 0/1-0/3.

Mode 1: Manual Aggregation

switch1 configuration:

Command
Description
switch (config)#link-aggregation 1 mode manual
Create manual aggregation group 1
switch (config)#port 0/1-0/3
Enter the port mode
switch (config-port-range)#link-aggregation 1 manual
Add a port into aggregation group in manual mode

switch2 configuration:
Command
Description
switch (config)#link-aggregation 1 mode manual
Create manual aggregation group 1
switch (config)#port 0/1-0/3
Enter the port mode
switch (config-port-range)#link-aggregation 1 manual
Add a port into an aggregation group in manual mode

Mode 2: Protocol Aggregation

switch1 configuration

Command
Description
switch (config)#link-aggregation 1 mode lacp
Create protocol aggregation group 1
switch (config)#port 0/1-0/3
Enter the port mode
switch (config-port-range)#link-aggregation 1 active
Add a port into an aggregation group in protocol mode

switch2 configuration:

Command
Description
switch (config)#link-aggregation 1 mode lacp
Create protocol aggregation group 1
switch (config)#port 0/1-0/3
Enter the port mode
switch (config-port-range)#link-aggregation 1 active
Add a port into an aggregation group in protocol mode

Monitoring Commands

View Commands:

Command
Description
show link-aggregation group [agg-id]
Display the aggregation information of a specified aggregation group
show link-aggregation port [port_no]
Display the aggregation information of a port

Debugging Commands

Command
Description
(no) debug lac [pdu [rx|tx] | machine | event ] [port port-no]
Enable the debugging switch of the information about link aggregating process.

Hope this information will help you for understanding of Link aggregation concept and configuration in Maipu Switches for Cisco it’s same. Cisco is having PAGP propriety protocol for Link aggregation.

Port Aggregation Protocol (PAGP)
  • Cisco Proprietary
  • Port Modes : Auto , Desirable , On


If Both side you set as a Auto mode then it will not become Ether Channel

  • Auto Means : It will say u want to be a Ether channel
  • Desirable Mode: It will u r Ether channel the I will be.
  • On: No Negotiating -- He will be only Ether channel and Destination Switch should be configured as a Ether channel. [ Better One ]

 PagP Configuration Example :-

SwitchA(config)# int range fastethernet 0/23 - 24
SwitchA(config- if)# channel-protocol PagP
SwitchA(config- if)# channel-group 1 mode desirable

SwitchB(config)# int range fastethernet 0/23 - 24
SwitchB(config- if)# channel-protocol PagP
SwitchB(config- if)# channel-group 1 mode auto

Thanks for reading , Hope this post is informative for you. For any feedback and queries Plz comment with your Name and Mail id. For easy options use Name/URL option. 

Wednesday, July 13, 2011

E-LAN services using QinQ-Maipu

In this section, I will share one testing report. This will help you to configure E-LAN services over Maipu Metro Ethernet switch network.

In this scenario, We are using Maipu 3400 switches and enabled QinQ technology in all switches to achieve ELAN and make reachable all connected routers. There is one more way of configuration using evc commands. But I feel this is easy to configure.

So I prefer this way.
Here is topology:

Topology


VLAN200 is used as outer vlan (ISP inside VLAN)in the backbone network. We are using QinQ tunnel technology to achieve ELAN services.

Objective - The requirement is Router-B can communicate with Router-A, Router-C can communicate with Router-A, and Router-B can’t communicate with Router-C.

Configurations:

Switch-A:

hostname SW-A

vlan 1      
 exit

vlan 100
 description ###control_VLAN###
 exit

vlan 200
 description ###outer_tag###
 exit

!slot_0_SM3400-24FET4GEFA
!slot 0
port 0/0
 port-type nni
 port mode trunk
 port trunk allowed vlan all
 port trunk pvid vlan 1
 no spanning-tree enable
 exit
port 0/1
 port-type nni
 port mode trunk
 port trunk allowed vlan all
 port trunk pvid vlan 1
 no spanning-tree enable
 exit
port 0/2
 port-type nni
 port mode hybrid
 port hybrid untagged vlan 1,200
 port hybrid pvid vlan 1
 vlan dot1q-tunnel enable
 vlan dot1q-tunnel drop
 vlan dot1q-tunnel 20,30 200
 exit

interface vlan1
 ip address 1.1.1.1 255.255.255.0
 exit

eips ring 1 master segment
 control vlan 100
 instance 0
 primary port 0/0
 secondary port 0/1
 eips start
 exit

Switch-B:

hostname SW-B

vlan 1      
 exit

vlan 100
 description ###control_VLAN###
 exit

vlan 200
 description ###outer_tag###
 exit

!slot_0_SM3400-24FET4GEFA
!slot 0
port 0/0
 port-type nni
 port mode trunk
 port trunk allowed vlan all
 port trunk pvid vlan 1
 no spanning-tree enable
 exit
port 0/1
 port-type nni
 port mode trunk
 port trunk allowed vlan all
 port trunk pvid vlan 1
 no spanning-tree enable
 exit
port 0/2
 port-type nni
 port mode hybrid
 port hybrid untagged vlan 1,200
 port hybrid pvid vlan 1
 vlan dot1q-tunnel enable
 vlan dot1q-tunnel drop
 vlan dot1q-tunnel 20 200
 exit

interface vlan1
 ip address 1.1.1.2 255.255.255.0
 exit

eips ring 1 transit segment
 control vlan 100
 instance 0
 primary port 0/0
 secondary port 0/1
 eips start
 exit

Switch-C:

hostname SW-C

vlan 1      
 exit

vlan 100
 description ###control_VLAN###
 exit

vlan 200
 description ###outer_tag###
 exit

!slot_0_SM3400-24FET4GEFA
!slot 0
port 0/0
 port-type nni
 port mode trunk
 port trunk allowed vlan all
 port trunk pvid vlan 1
 no spanning-tree enable
 exit
port 0/1
 port-type nni
 port mode trunk
 port trunk allowed vlan all
 port trunk pvid vlan 1
 no spanning-tree enable
 exit
port 0/2
 port-type nni
 port mode hybrid
 port hybrid untagged vlan 1,200
 port hybrid pvid vlan 1
 vlan dot1q-tunnel enable
 vlan dot1q-tunnel drop
 vlan dot1q-tunnel 30 200
 exit

interface vlan1
 ip address 1.1.1.3 255.255.255.0
 exit

eips ring 1 transit segment
 control vlan 100
 instance 0
 primary port 0/0
 secondary port 0/1
 eips start
 exit

Router-A:

interface fastethernet0.20
 ip address 20.1.1.1 255.255.255.0
 encapsulation dot1q 20
 exit

interface fastethernet0.30
 ip address 30.1.1.1 255.255.255.0
 encapsulation dot1q 30
 exit

Router-B:

interface fastethernet0.20
 ip address 20.1.1.2 255.255.255.0
 encapsulation dot1q 20
 exit

Router-C:

interface fastethernet0.30
 ip address 30.1.1.2 255.255.255.0
 encapsulation dot1q 30
 exit

Result:

On the router A, router A can ping to router B and router C both


But router B can’t communicate with Router-C because they are in different VLAN:



Check the switch:



IOS version:

sp1-g-6.2.19.pck
size: 7979128bytes




Hope this configuration will help you in deployment of ELAN.
For any queries and feedback, Plz comment with your Name and mail id, you can use NAME/URL option.
  

Related Posts Plugin for WordPress, Blogger...