Ads 468x60px

Wednesday, August 25, 2010

Basic MPLS

This post is for new engineers, those who are learning MPLS L3 VPN. This post include a link of full lab with configuration files.
In this Lab vrf VPN_A from PE to CE , I used BGP and OSPF. For vrf VPN_B EIGRP and static. So Here you will find basic configuration of all protocols between CE to PE. Same time you will see the redistribution.

This topology I am going to use for configurations.
1.       R1 and R6 are in vrf VPN_A,R1 is using BGP to exchange the routes with PE-1 and R6 is using OSPF to share the routes with PE-2.
2.       R7 and R8 are in vrf VPN_B, R7 is using EIGRP to exchange the routes with PE-1 and R8 is using static routes with PE-2.
3.       In Core, OSPF is used as IGP.
4.       MP-IBGP is configured in PE-1 and PE-2.
Here is PE 1 and PE-2 configurations, Download full lab and configuration from link.

PE-1

hostname PE-1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!

!
!
ip vrf VPN_A
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
ip vrf VPN_B
 rd 100:2
 route-target export 100:2
 route-target import 100:2
!
no ip domain lookup
!
mpls label protocol ldp
!
!
interface Loopback0
 ip address 100.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.10
 encapsulation dot1Q 10
 ip vrf forwarding VPN_A
 ip address 10.1.1.2 255.255.255.252
!
interface FastEthernet0/0.30
 encapsulation dot1Q 30
 ip vrf forwarding VPN_B
 ip address 192.168.1.2 255.255.255.252
!
interface FastEthernet0/1
 ip address 172.16.1.1 255.255.255.252
 duplex auto
 speed auto
 mpls label protocol ldp
 mpls ip
!
!
router eigrp 200
 auto-summary
 !
 address-family ipv4 vrf VPN_B
 redistribute bgp 100 metric 256 20 200 100 20
 network 192.168.1.0 0.0.0.3
 no auto-summary
 autonomous-system 100
 exit-address-family
!
router ospf 1
 log-adjacency-changes
 network 100.1.1.1 0.0.0.0 area 0
 network 172.16.1.0 0.0.0.3 area 0
!
router bgp 100
 bgp log-neighbor-changes
 neighbor 100.1.1.3 remote-as 100
 neighbor 100.1.1.3 update-source Loopback0
 !
 address-family ipv4
 neighbor 100.1.1.3 activate
 neighbor 100.1.1.3 next-hop-self
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 100.1.1.3 activate
 neighbor 100.1.1.3 send-community extended
 neighbor 100.1.1.3 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf VPN_B
 redistribute eigrp 100
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf VPN_A
 neighbor 10.1.1.1 remote-as 200
 neighbor 10.1.1.1 activate
 no synchronization
 exit-address-family
!
ip http server
no ip http secure-server
!
!
control-plane

!
line con 0
line aux 0
line vty 0 4
!
!
end

PE-2:

hostname PE-2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
ip vrf VPN_A
 rd 100:1
 route-target export 100:1
 route-target import 100:1
!
ip vrf VPN_B
 rd 100:2
 route-target export 100:2
 route-target import 100:2
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
 ip address 100.1.1.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 172.17.1.2 255.255.255.252
 duplex auto
 speed auto
 mpls label protocol ldp
 mpls ip
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/1.20
 encapsulation dot1Q 20
 ip vrf forwarding VPN_A
 ip address 20.1.1.2 255.255.255.252
!
interface FastEthernet0/1.40
 encapsulation dot1Q 40
 ip vrf forwarding VPN_B
 ip address 192.168.2.2 255.255.255.252
!
!
router ospf 2 vrf VPN_A
 log-adjacency-changes
 redistribute bgp 100 subnets
 network 20.1.1.0 0.0.0.3 area 0
!
router ospf 1
 log-adjacency-changes
 network 100.1.1.3 0.0.0.0 area 0
 network 172.17.1.0 0.0.0.3 area 0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 neighbor 100.1.1.1 remote-as 100
 neighbor 100.1.1.1 update-source Loopback0
 neighbor 100.1.1.1 next-hop-self
 no auto-summary
 !
 address-family vpnv4
 neighbor 100.1.1.1 activate
 neighbor 100.1.1.1 send-community extended
 neighbor 100.1.1.1 next-hop-self
 exit-address-family
 !
 address-family ipv4 vrf VPN_B
 redistribute connected
 redistribute static
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf VPN_A
 redistribute ospf 2 vrf VPN_A
 no synchronization
 exit-address-family
!
ip route vrf VPN_B 6.6.6.6 255.255.255.255 192.168.2.1
!
!
ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

LAB Link :
http://www.ziddu.com/download/11368307/basicmpls.rar.html


I hope this lab will helpful for beginners.Post comments for any queries.






11 comments:

NetWorking said...
This comment has been removed by the author.
Minal said...

We are not able to open the link. its showing " The file You are looking for... may be deleted by the user or by the Administrator"
Can you please share that .rar document again?

Uttamkumar said...

Hi Minal,
I checked the file has been deleted by Ziddu. you can use above configuration to setup PE routers. In case you need more documents. Plz share your mail ID. I will mail you same..

Unknown said...

QF0721
christian louboutin shoes
uggs outlet
chanel outlet
tommy hilfiger outlet
coach outlet store
five fingers shoes
lakers jersey
toms outlet
juicy couture outlet
soccer shoes
supra shoes
lebron 12 shoes
mlb jerseys
49ers jersey
ray ban sunglasses outlet,ray ban sunglasses,ray ban,rayban,ray bans,ray ban outlet,ray-ban,raybans,ray ban wayfarer,ray-ban sunglasses,raybans.com,rayban sunglasses,cheap ray ban
north face jackets,north face,the north face,northface,north face outlet,north face jackets clearance,the north face
tory burch sandals
christian louboutin uk
coach outlet online
chicago bears jerseys
san antonio spurs jerseys
colts jerseys
nike free run uk
michael kors uk

xumeiqing said...

151215meiqing
gucci shoes
cheap uggs
jordans
michael kors outlet online
polo ralph lauren
ugg boots on sale
cheap nfl jerseys
ugg boots sale
coach outlet
coach factory outlet
ugg boots
gucci outlet
louis vuitton outlet
polo ralph lauren outlet
coach outlet store online
coach outlet
toms outlet
cheap oakley sunglasses
louis vuitton purses
canada goose jackets
michael kors bag
chanel bags
ugg boots
nike free run
jordan concords
canada goose outlet
michael kors outlet
uggs boots
nike air max
jordan retro
louis vuitton outlet
chanel handbags
abercrombie
michael kors handbags
oakley sunglasses
ugg outlet
uggs sale
hollister uk
beats by dre
north face jackets

John said...

michael kors outlet
ugg boots on sale
canada goose jackets
kobe 10s
chanel outlet
coach outlet store online
ugg outlet
uggs for women
air max 90
louis vuitton handbags
air force 1
coach factory outlet
ralph lauren outlet
louis vuitton purses
ray-ban sunglasses
coach outlet
tod's shoes
coach outlet online
chanel bags
supra shoes
louis vuitton purses
ugg boots
marc jacobs handbags
ugg sale
michael kors outlet online
coach outlet
tory burch outlet online
louis vuitton outlet
soccer shoes
coach outlet
louis vuitton handbags
michael kors outlet
ugg outlet
michael kors outlet
christian louboutin shoes
p90x
cheap toms
michael kors outlet store
2016222yuanyuan

Unknown said...

north face jackets
ugg outlet
louis vuitton borse
ed hardy
nike huarache black
coach outlet online
white converse
toms outlet
reebok shoes
coach outlet online
coach factory outlet online
ugg sale
coach outlet online
louis vuitton handbags
louis vuitton purse
kate spade outlet
true religion jeans outlet
ferragamo outlet
ugg australia outlet
michael kors outlet
michael kors outlet online
stephen curry basketball shoes
ralph lauren uk
ray ban outlet store online
coach outlet store
ecco outlet
michael kors outlet online
michael kors outlet online
yeezy boost
birkenstocks
20160725caiyan

kh said...


شركة تنظيف خزانات بجدة الجوهرة من افضل شركات تنظيف الخزانات بجدة حيث ان تنظيف خزانات بجدة يحتاج الى مهارة فى كيفية غسيل وتنظيف الخزانات الكبيرة والصغيرة بجدة على ايدى متخصصين فى تنظيف الخزانات بجدة
شركة تنظيف خزانات بجدة

اهم شركات نقل العفش والاثاث بالدمام والخبر والجبيل اولقطيف والاحساء والرياض وجدة ومكة المدينة المنورة والخرج والطائف وخميس مشيط وبجدة افضل شركة نقل عفش بجدة نعرضها مجموعة الفا لنقل العفش بمكة والخرج والقصيم والطائف وتبوك وخميس مشيط ونجران وجيزان وبريدة والمدينة المنورة وينبع افضل شركات نقل الاثاث بالجبيل والطائف وخميس مشيط وبريدة وعنيزو وابها ونجران المدينة وينبع تبوك والقصيم الخرج حفر الباطن والظهران
شركة نقل عفش بجدة
شركة نقل عفش بالمدينة المنورة
شركة نقل عفش بالرياض
شركة نقل عفش بالدمام

Bách ngọc said...

giày công sở nam
bán sỉ giày nam
Giày nam cao cấp
giày da nam
mua buôn giày nam ở đâu
bán sỉ giày nam
mua buôn giày nam ở đâu
địa chỉ mua buôn giày nam

Anonymous said...

you need the latest news and updated? just visit our website ... judi bola we will provide updated and interesting information .. do not miss it .. come see now our website. click here too

yanmaneee said...

supreme clothing
golden goose sneakers
moncler
stephen curry shoes
kyrie 5 shoes
nike off white
kobe sneakers
nike lebron 16
jordan shoes
jordan shoes

Post a Comment

Related Posts Plugin for WordPress, Blogger...