As discussed in last post, In this section we will see configuration examples for 802.1x for Maipu routers and Switches, Here I covered Client base authentication, Mac base authentication, Radius based authentication.
Device Used - MP 1800 series
802.1X Client Authentication
Topology Details
As shown in diagram, one user is connected to Port 0/1 of the device. The device manager of the device hopes to perform the 802.1X authentication for the user access on the port, so as to control the access for Internet.
Requirements:
- During the authentication, use the Radius authentication mode (the keys of the device and server are both set as maipu).
- When the user does not pass the authentication, he can access the Update Server (Update Server is in Vlan 10).
- After passing the authentication, the user can access Internet (the port of the device connected to Internet is in VLAN 5).
- After the user passes the authentication, the other users on the port can access Internet without authentication.
Topology
802.1x configuration diagram
Description
A host accesses the network via 802.1X authentication. The authentication server is a radius server. The accessed port 0/1 of the client host (Supplicant) is in the VLAN 1; the authentication server is in the VLAN 2; the Update Server is used for downloading and upgrading the client software, is in the VLAN 10; the port 0/2 connects to Internet of the switch is in the VLAN 5.
Configuration-
Command | Description |
router#conf terminal | Enter the configuration mode |
router(config)#aaa new-model | Enable the AAA mode |
router(config)#aaa authentication connection default radius | Configure AAA as the radius authentication mode |
router(config)#radius-server host 128.255.42.1 key maipu | Configure the radius server address and key |
router(config)#vlan 2 | Create vlan2 |
router(config-vlan2)#exit | Exit the vlan configuration mode |
router(config)#port 0/3 | Enter the port configuration mode |
router(config-port-0/3)#port access vlan 2 | Add port 0/3 into VLAN 2 |
router(config-port-0/3)#exit | Exit the port configuration mode |
router(config)#interface vlan 2 | Enter the interface configuration mode |
router(config-if-vlan2)#ip address 128.255.42.10 255.255.255.0 | Configure the address information of vlan2 interface |
router(config-if-vlan2)#exit | Exit the interface configuration mode |
router(config)#vlan 5 | Create vlan5 |
router(config-vlan5)#exit | Exit the vlan configuration mode |
router(config)#port 0/2 | Enter the port configuration mode |
router(config-port-0/2)#port access vlan 5 | Add port 0/2 into VLAN 5 |
router(config-port-0/2)#exit | Exit the port configuration mode |
router(config)#vlan 10 | Create vlan 10 |
router(config-vlan10)#exit | Exit the vlan configuration mode |
router(config)#port 0/4 | Enter the port configuration mode |
router(config-port-0/4)#port access vlan 10 | Add port 0/4 into vlan10 |
router(config-port-0/4)#port 0/1 | Switch to port 0/1 configuration mode |
router(config-port-0/1)#dot1x port-control enable | Enable the 802.1X authentication mode |
router(config-port-0/1)#dot1x port-method portbased | Configure the port-based access control mode |
router(config-port-0/1)#dot1x guest-vlan 10 | Configure vlan10 as guest vlan |
router(config-port-0/1)#exit | Exit the port configuration |
router(config)# | |
802.1x configuration diagram
The port 0/1 is added into the Guest VLAN, and the supplicant and update server are both in VLAN10 at the time. The supplicant can access the Update Server and download the 802.1X client:
802.1x configuration diagram
When the user passes the authentication and is online, the authentication server assigns VLAN 5. Right now the supplicant and port 0/2 are both in VLAN 5, and the Supplicant can access the Internet.
Let’s have look for MAC base authentication -
MAC Address Authentication
Local Authentication
Topology Details -
As shown in diagram, one user is connected to port 0/0 of the device. The manager of the device hopes to perform the MAC address authentication for the user access on the port, so as to control the access for Internet.
Requirements:
- The device detects whether the user is offline with an interval of 120s.
- After the user authentication fails, the authentication can be performed again only after 5 minutes.
- During the authentication, use the local authentication mode.
- Use the source MAC of the user as the user name and password and the MAC address uses the hyphen “-“.
Topology
Local authentication mode
Configuration
Command | Description |
router#conf terminal | Enter the configuration mode |
router(config)#user | Configure the local user; the user name and password are the MAC address of the user to be connected |
router(config)#aaa new-model | Enable the AAA mode |
router(config)#aaa authentication connection default local | Configure the AAA local authentication mode |
router(config)#port 0/0 | Enter the port configuration mode |
router(config-port-0/0)#dot1x timeout offline-detect 120 | Configure performing the offline detection for the user with an interval of 120s |
router(config-port-0/0)#dot1x timeout quiet-period 300 | Configure the quiet time as 5 minutes (300s) after the user authentication fails |
router(config-port-0/0)#dot1x mac-authentication enable | Enable the MAC authentication function on the port |
router(config-port-0/0)#dot1x mac-authentication user-name-format mac-address with-hyphen | Configure the MAC authentication user name format: use the MAC information with hyphen “-“ as the use name and password (the option is the default configuration) |
router(config-port-0/0)#exit | Exit the port configuration mode |
The show running-config command is used to view the current configuration information:
router#show running-config
Building Configuration...done
……
user 00-01-7 a-22-22-33 password 0 00-01-7a -22-22-33
……
aaa new-model
aaa authentication connection default local
……
port 0/0
dot1x timeout offline-detect 120
dot1x timeout quiet-period 300
dot1x mac-authentication enable
exit
……
Let’s have look for Radius Authentication -
RADIUS Authentication
Topology Details
As shown in diagram, one user is connected to port 0/0 of the device. The device manager hopes to perform the MAC address authentication for the user access on the port, so as to control the access for Internet.
Requirements:
- The device detects whether the user is offline with an interval of 120s.
- After the user authentication fails, the authentication can be performed again only after 5 minutes.
- During the authentication, use the Radius authentication mode (set the keys of the device and server as maipu).
- During the authentication, adopt the fixed user name format; the user name is abcd and the password is 1234.
Topology
Radius authentication mode
Configuration
Note-
When using RADIUS authentication, ensure that the route between the device and the RADIUS is available and add the user name and password successfully on the RADIUS server.
Command | Description |
router#conf terminal | Enter the configuration mode |
router(config)#aaa new-model | Enable the AAA mode |
router(config)#aaa authentication connection default radius | Configure AAA as the radius authentication mode |
router(config)#radius-server host 128.255.42.1 key maipu | Configure the Radius server address and key |
router(config)#interface vlan 1 | Enter the interface configuration mode |
router(config-if-vlan1)#ip address 128.255.42.10 255.255.255.0 | Configure the address information of vlan1 interface |
router(config-if-vlan1)#exit | Exit the interface configuration mode |
router(config)#port 0/0 | Enter the port configuration mode |
router(config-port-0/0)#dot1x timeout offline-detect 120 | Configure performing the offline detection for the user with an interval of 120 |
router(config-port-0/0)#dot1x timeout quiet-period 300 | Configure the quiet time as 5 minutes after the user authentication fails (300s) |
router(config-port-0/0)#dot1x mac-authentication enable | Enable the port MAC authentication function |
router(config-port-0/0)#dot1x mac-authentication user-name-format fixed account abcd password 1234 | Configure the MAC authentication user name format: fixed user name format; the user name is abcd and the password is 1234 |
router(config-port-0/0)#exit | Exit the port configuration mode |
The show running-config command can be used to view the current configuration information:
router#show running-config
Building Configuration...done
……
aaa new-model
aaa authentication connection default radius
……
port 0/0
dot1x timeout offline-detect 120
dot1x timeout quiet-period 300
dot1x mac-authentication enable
dot1x mac-authentication user-name-format fixed account abcd password 1234
exit
……
interface vlan1
ip address 128.255.42.10 255.255.255.0
exit
radius-server host 128.255.42.1 auth-port 1645 acct-port 1646 priority 0 key maipu
……
Monitoring Commands
Command | Description |
show dot1x | Display the default parameter information of 802.1x |
show dot1x statistic | Display the 802.1x statistics information |
show dot1x user {port|link-aggregation|summary } | Display the 802.1x user information of the specified port. If the port is not specified, display all user information. If summary is input, display the user quantity information. |
show dot1x config {port|link-aggregation} | Display the 802.1x configuration of a specified port; if no port is specified, display the 802.1x configuration of all ports (the ports which are not configured with any 802.1x item are not displayed) |
Monitoring Command Output
For environment and configuration, refer to client base authentication
router#show dot1x user
Displayed result:
NO. VLAN MAC_ADDRESS PORT NAME STATUS IP_ADDRESS USERTYPE USERNAME
---- ---- -------------- ------------------- ------------- --------------- -------- --------
1 10 0005.5de4.0e25 port 0/1 Unauthoriz ed 128.255.42.111 DOT1X abcd
Total: 1 Authoriz ed: 0 Unauthorized: 1 Unknown: 0
Description and analysis:
No: user serial number
VLAN: the VLAN of the user port
MAC_ADDRESS: user MAC address
PORT NAME: port name
STATUS: user authorization status
IP_ADDRESS: user IP address
USERTYPE: the user type (DOT1X user or MAC authentication user)
USERNAME: user name
Debug Command
View the user login authentication information via the command debug dot1x all.
Hope this configuration will help you for 802.1x configurations.
For any queries and feedback, Plz put comment with Name and mail id . you can use Name/URL option in profile ...
For any comments and feedback.Plz comment with your mail and Name, you can use Name/URL option in profile.
36 comments:
Тhanks to my fаther who told me concerning this wеb site, this ωebpagе is in faсt amazіng.
my weblog ... google link analyzer
QF0721
coach outlet online
ray ban outlet
vibram fivefingers
new york knicks jersey
coach outlet
los angeles clippers jerseys
ysl outlet
football shirts uk,soccer jerseys uk,cheap soccer jerseys uk
tommy hilfiger outlet store
tommy hilfiger outlet online
the north face outlet
cartier watches
north face outlet online
kevin durant jersey
moncler coats
robert griffin jersey,joe theismann jersey,andre roberts jersey,sonny jurgensen jersey,art monk jersey,bashaud breeland jersey,barry cofield jersey,perry riley jersey,e.j. biggers jersey,duke ihenacho jersey,josh morgan jersey
eagles jerseys
nike free run
tory burch shoes
carmelo anthony jersey
fivefingers shoes
kobe bryant shoes
ysl outlet online
2016-1-8 leilei
coach outlet
prada handbags
ralph lauren pas cher
jordan 3 white cenment
louis vuitton handbags
retro jordans 13
christian louboutin sale
coach outlet online
true religion sale
ugg outlet
north face jackets
mulberry uk
ralph lauren outlet
ugg boots
louis vuitton handbags
jordan 6s
montblanc pens
cheap ugg boots
louboutin pas cher
michael kors outlet
michael kors outlet
oakley vault
canada gooses outlet
coach outlet online
adidas uk
longchamp le pliage
burberry outlet
cheap uggs
gucci belt
louis vuitton outlet stores
adidas gazelle
jordan 3s
michael kors handbags
sac longchamp pliage
michael kors handbags
gucci handbags
ed hardy
kate spade
tory burch
air jordan homme
giuseppe zanotti
canada goose outlet
tory burch boots
chanel handbags
louis vuitton outlet stores
timberland outlet
michael kors outlet
gucci outlet
kevin durant 8
celine bags
michael kors handbags
abercrombie and fitch
louis vuitton bags
michael kors outlet
oakley sunglasses wholesale
oakkey sunglasses
nfl jerseys
cheap uggs
ray ban sunglasses uk
toms outlet
tods outlet online
north face
louis vuitton outlet stores
true religion outlet
ugg outlet
cheap nfl jerseys
cheap jordan shoes
canada goose outlet
uggs outlet
concord 11
kobe shoes
cheap jordans
christian louboutin
true religion jeans outlet
fit flops
canada goose outlet store
hollister clothing
cheap rolex watches
2016222yuanyuan
michael kors outlet clearance
cheap ray bans
burberry outlet online
christian louboutin outlet
white converse
the north face outlet
cheap ray bans
sac longchamp pliage
louboutin pas cher
louis vuitton handbags
toms outlet store
polo ralph lauren
michael kors outlet online
canada goose sale
chi flat iron
omega replica watches for sale
nike free runs
louis vuitton outlet
ugg outlet
yeezy boost 350 white
michael kors outlet online
adidas nmd r1
tiffany jewelry
rolex watches
armani exchange
mlb jerseys wholesale
moncler outlet online
burberry outlet canada
louis vuitton outlet online
polo ralph lauren outlet
nike air force
christian louboutin uk
20160725caiayn
patriots jerseys
ugg outlet
adidas nmd
louis vuitton outlet
kate spade
the north face
ralph lauren
longchamp pas cher
ugg boots
michael kors bags
chenyingying20170114
nike air max
louis vuitton
toms outlet
michael kors factory outlet
louis vuitton outlet
polo ralph lauren outlet
fitflops sale
asics
tory burch outlet
michael kors canada
20170214lck
oklahoma city thunder jerseys
michael kors handbags outlet
cheap nike shoes
michael kors handbags
49ers jersey
michael kors handbags
the north face
abercrombie and fitch
michael kors handbags
nike air max 90
michael kors outlet online
michael kors handbags
hermes birkin bag
christian louboutin
coach outlet store online
ed hardy shirts
caterpillar work boots
omega speedmaster
instyle hair iron
toms outlet
2017.3.16chenlixiang
cheap nfl jerseys
lions jerseys
mont blanc pens
ralph lauren polo
cheap jerseys
cheap jordan shoes
cincinnati bengals jerseys
michael kors handbags
coach outlet online
calvin klein outlet
vapormax
fila shoes
air max 97
michael kors outlet
kobe 11
jordan shoes
yeezy shoes
timberland
jordan sneakers
cheap jordans
calvin klein outlet
nike x off white
bape hoodie
supreme outlet
jordan shoes
golden goose
yeezys
curry 7
bape hoodie
Post a Comment